Získání Subclipse v Aptana pracovat s nejnovějším vydáním Subversion

hlasů
34

Verze Subclipse (1.2.4), v současné době k dispozici prostřednictvím automatických Aptana je správce zásuvných modulů nepracuje s nejnovější verzí Subversion.

Vidím, že na webových stránkách Subclipse však, že mají 1.4.2 pozor na Eclipse. Tak jsem přidal novou vzdálenou aktualizaci stránky do mého manažera Update. Když jsem se pokusil nainstalovat, to mi řekl, že jsem potřeboval Mylyn 3.0.0 . Takže po dlouhém hledání jsem našel Mylyn 3.0.0 a přidal další nový dálkový aktualizace stránky do mého manažera aktualizace. Pak, když jsem se pokusil nainstalovat, že mi to řekl, potřeboval jsem org.eclipse.ui 3.3.0 nebo ekvivalentní.

Podíváme-li se na podrobnosti konfigurace pro Aptana, vypadá to, že je postaven před zatmění 3.2.2.

Ví někdo, jestli existuje způsob, jak upgradovat na verzi Eclipse Aptana, který je postaven proti na 3.3.0? Nebo pokud je nějaký jiný způsob, jak dostat Subclipse pracovat s velmi nejnovější verzi Subversion?

Vím, že to není nutně „programování“ otázka, ale já doufám, že je to v pořádku, protože je to velmi důležité pro zkušeností s programováním.

Položena 01/08/2008 v 14:56
zdroj uživatelem
V jiných jazycích...                            


4 odpovědí

hlasů
16

Subclipse nevyžaduje Mylyn, ale aktualizace web obsahuje plugin, který integruje Mylyn a Subclipse. Toto je určen pro lidi, kteří používají Mylyn. Ve vašem případě, by se chcete jen de-select Mylyn v dialogovém okně aktualizace.

Subclipse také vyžaduje Subversion 1.5 a odpovídající verze JavaHL nativních knihoven. Napsal jsem na začátku FAQ pomoci lidem pochopit JavaHL a jak jej získat. Viz: http://desktop-eclipse.open.collab.net/wiki/JavaHL

Odpovězeno 15/09/2008 v 14:26
zdroj uživatelem

hlasů
6

Měl jsem problémy s JavaHL v Eclipse Ganymede, když to fungovalo v Eclipse Europa. Nejsem si jistý, jak Aptana je jiný, ale zkuste to buď upgrade JavaHL nebo přechod k provádění čistě java SVNKit rámci Subclipse config.

Odpovězeno 01/08/2008 v 15:41
zdroj uživatelem

hlasů
4

pokud nebude používat Mylyn pouze zrušte tuto závislost. Nejsem obeznámen s Aptana, ale zatmění můžete rozšířit co instalaci a zrušte něco, co nepotřebujete.

Odpovězeno 29/08/2008 v 00:47
zdroj uživatelem

hlasů
3

Použil jsem URL aktualizace a jsem nainstaloval adaptér JavaHL, na Subclipse samotný projekt a na SVNKit adaptéru BETA.

Poté fungovalo to dobře pro mě, je to pro linux platformu doufám, že to funguje u vás.

Odpovězeno 26/08/2008 v 14:41
zdroj uživatelem

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more